Javscript

Yeni Meteor 2.7.3 ve 2.5 için yeni bir yama sürümü | tarafından Denilson Silva | Haz, 2022

Herkese merhaba. Meteor 2.7.3, Düğüm ile ilgili güncellemeleri şuraya getiriyor: 14.19.3, bu da güvenlik güncellemelerini tanıttı. Değişiklik günlüklerini görebilirsiniz burada ve burada daha fazla ayrıntı için. Meteor, 2.3’te Düğüm 14’ü tanıttığından ve 2.3 ile 2.5 arasında önemli bir kırılma değişikliği olmadığından, yeni 2.5.7 yamasını yayınladık.

2.6 sürümünde, için destek ekledik MongoDB 5.0bu, kodunuz kullanıyorsa uygulamanızda kırılma değişikliklerine neden olabilecek yeni bir API getirdi. rawCollection veya doğrudan MongoDB sürücüsü ile etkileşime girer. Bu nedenle, uygulamanız hala 2.6 sürümünün altındaysa, şimdi güncelleyebilirsiniz. 2.5.7 ve Düğüm güncellemesinden yararlanın. Npm ayrıca 6.14.17 sürümüne güncellendi.

Bu güncelleme, bu yeni sürümdeki tek şey değildi. her şeyi kontrol edebilirsiniz değişiklik günlüğü. Aşağıda öne çıkanlardan bazılarını görebilirsiniz.

Müşteriyi küçültme

bu @babel/runtime‘nin package.json dosyası 25 kb’ın üzerinde. Meteor paketi, güncellenmesi gerektiğinde bir mesaj göstermek için onu hem sunucuya hem de istemciye aktardı. Bu mesaj gereksiz yere kopyalandığı için istemciden kaldırdık. Mesaj olmadan, artık babil’i müşteriye aktarmamız gerekmiyor, dolayısıyla müşteri boyutunu küçültüyoruz.

ayarlama accounts-passwordless paket

İşlevi arayarak bir oturum açma belirteci talep edebilirsiniz. requestLoginTokenForUser. Ancak, sağlanan e-posta biçimine bağlı olarak belirteç gönderilmeyebilir ve bu gerçekleşirse herhangi bir uyarı atılmaz. Bu davranış artık olmuyor. Şimdi e-postayı sunucuda karşılaştırırken büyük/küçük harf duyarlı olmadığından emin oluyoruz ve herhangi bir nedenle jeton gönderilmezse bir uyarı atılır.

İlgili Makaleler

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

Başa dön tuşu